Workbench Desktop App add-in for SolidWorks®

Getting the most from Workbench

If you are a SolidWorks user with Workbench, the add-in puts many of the features that make Workbench a great CAD collaboration tool at your fingertips. Read below to learn how to:

Installing the add-in

The Workbench Desktop App comes packaged with the add-in if you have SolidWorks on your computer when you install it.

If you already have the Desktop App installed when you install SolidWorks, you will need to uninstall Workbench from the Control Panel and reinstall at http://grabcad.com/downloadworkbench

Once the add-in is installed, it will appear in both the command ribbon and task pane of SolidWorks

Task Pane actions

1
Open project on Workbench - Opens the Workbench web interface in your default browser where you can make project actions, such as manage collaborators or update Partner Spaces.
2
Download - Shows the list of pending changes waited to be downloaded. You can click "Download" again to begin the download. If you have conflicting changes,  see here to learn how to resolve them.
3
Open local folder - Opens the linked project folder in a Windows Explorer window. 
4
Upload changes - Shows the list of pending changes waited to be uploaded. Enter an upload comment and click "Upload" again to begin the upload. If you have conflicting changes,  see here to learn how to resolve them. 
Note: only saved changes can be uploaded. Hit File > Save to see your changes here.
	
5
New Connection - Creates a new manual connection. To connect a project to a folder in your GrabCAD folder, please use the standalone Workbench Desktop App. 
6
Connection menu
  • Refresh connection - Checks the local folder and Workbench project for updates. Connections should refresh automatically when there are changes, but in certain cases changes are not recognized unless the connection is manually refreshed, such as if the connected folder is on a network drive.
  • Add collaborators - Opens the Users tab of the Workbench project in your default web browser
  • Delete connection - Only available on manually connected projects, this will disconnect the linked local folder. 
7
Main menu
  • Options - Opens the Options menu for the GrabCAD add-in. See below.
  • Logout - Logs the current user out of the add-in.
  • Update Workbench - Available if there is a new version of Workbench available to download. For best results, close SolidWorks, update using the standalone Workbench Desktop App, then restart SolidWorks.
  • I Wish... - Allows the user to send a message to GrabCAD's support team. Use this functionality to request features or report issues. 
  • Home - Exits the Download or Upload screens. 
  • Help - Opens help.grabcad.com in your default web browser
  • Send logs - Sends a log of your Workbench actions to our support team. 
  • About - Shows the current version of the Workbench add-in

Command Ribbon actions

  • Options - Opens the Options menu for the GrabCAD add-in. See below.
  • About - Lets you know which version of GrabCAD you have installed.
  • Lock - Allows you to lock the file being viewed if it is managed by Workbench.
  • Unlock - Allows you to unlock the file being viewed. If the file was locked by your teammate, you will be prompted to add a comment explaining why you are unlocking the file. 
  • Upload - Brings you to the upload panel in the Task Pane for the project containing the file being viewed if there are pending changes to upload.
  • Download - Brings you to the download panel in the Task Pane for the project containing the file being viewed if there are pending changes to download.

Overlay notifications

The add-in will notify you about information pertaining to the file currently being viewed. 

These notifications can tell you if the file you are viewing or the components within...

  • ...have been locked by a collaborator. Click the lock button to unlock the file if necessary. 
  • ...have been modified locally but not locked. Click the lock button to lock the file and dismiss the message. 
  • ...have new versions available to download. Click the blue cloud to go to the download screen.
  • ...are in a folder locally that is not connected to a Workbench project. (Components of assembly only) Click "Details" for more information.

Options

  • Export SLDDRW to PDF for Workbench Projects - Every drawing file that you save after enabling this setting will also be save as a PDF file with the same name in the same folder. In this way, you can keep a PDF copy of the file up to date on Workbench without having to make a new export each time you save
  • Show lock and update notifications in SolidWorks Window - You can turn on and off all overlay notifications with this setting
    • Warn me when I am editing a file I have not locked - You can turn on and off specifically the overlay notifications that let you know you have modified an unlocked file
  • Allow SolidWorks models to be replaced whilst open - When an overlay notification lets you know that there are new versions of the file or components available to download, this setting allows the model to instantly refresh after downloading the new versions. Without this setting, you will need to hit "rebuild" after downloading new versions to see the changes. 

SolidWorks is a registered trademark of Dassault Systèmes SolidWorks Corporation.

Can't find what you need? Send us a message Send us a message